What’s Vulnerable › Vulnerabilities

CVE-2022-2229

Description

An improper authorization issue in GitLab CE/EE affecting all versions from 13.7 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1 allows an attacker to extract the value of an unprotected variable they know the name of in public projects or private projects they're a member of.

Affected products

How to fix

Upgrade to a fixed version: GitLab 14.10.5, 15.0.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-2229 or the next vulnerability affects your stack