What’s Vulnerable › Vulnerabilities
CVE-2022-22299
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-05 · updated 2026-06-17
- Weakness: CWE-134
Description
A format string vulnerability [CWE-134] in the command line interpreter of FortiADC version 6.0.0 through 6.0.4, FortiADC version 6.1.0 through 6.1.5, FortiADC version 6.2.0 through 6.2.1, FortiProxy version 1.0.0 through 1.0.7, FortiProxy version 1.1.0 through 1.1.6, FortiProxy version 1.2.0 through 1.2.13, FortiProxy version 2.0.0 through 2.0.7, FortiProxy version 7.0.0 through 7.0.1, FortiOS version 6.0.0 through 6.0.14, FortiOS version 6.2.0 through 6.2.10, FortiOS version 6.4.0 through 6.4.8, FortiOS version 7.0.0 through 7.0.2, FortiMail version 6.4.0 through 6.4.5, FortiMail version 7.0.0 through 7.0.2 may allow an authenticated user to execute unauthorized code or commands via specially crafted command arguments.
Affected products
- Fortinet FortiADC: from 6.0.0 through 6.0.4; from 6.1.0 through 6.1.6; 6.2.0, 6.2.1
- Fortinet FortiMail: from 6.4.0 through 6.4.5; from 7.0.0 through 7.0.2
- Fortinet FortiOS (FortiGate): from 5.0.0 through 5.0.14; from 5.2.0 through 5.2.15; from 5.4.0 through 5.4.13; from 5.6.0 through 5.6.14; from 6.0.0 through 6.0.14; from 6.2.0 through 6.2.10 — fixed in 6.4.8, 7.0.2
- Fortinet FortiProxy: from 1.0.0 through 1.0.7; from 1.1.0 through 1.1.6; from 1.2.0 through 1.2.13; from 2.0.0 through 2.0.7; 7.0.0, 7.0.1
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 6.4.8, 7.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-22299 or the next vulnerability affects your stack