What’s Vulnerable › Vulnerabilities
CVE-2022-22315
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-27 · updated 2026-06-17
Description
IBM UrbanCode Deploy (UCD) 7.2.2.1 could allow an authenticated user with special permissions to obtain elevated privileges due to improper handling of permissions. IBM X-Force ID: 217955.
Affected products
- IBM UrbanCode Deploy: from 6.2.7.0 before 6.2.7.15; from 7.0.3.0 before 7.0.5.10; from 7.1.0.0 before 7.1.2.6; from 7.2.0.0 before 7.2.2.1 — fixed in 6.2.7.15, 7.0.5.10, 7.1.2.6, 7.2.2.1
How to fix
Upgrade to a fixed version: IBM UrbanCode Deploy 6.2.7.15, 7.0.5.10, 7.1.2.6, 7.2.2.1. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/217955
- https://www.ibm.com/support/pages/node/6575143
- https://exchange.xforce.ibmcloud.com/vulnerabilities/217955
- https://www.ibm.com/support/pages/node/6575143
Get alerted when CVE-2022-22315 or the next vulnerability affects your stack