What’s Vulnerable › Vulnerabilities
CVE-2022-22327
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-01 · updated 2026-06-17
- Weakness: CWE-327
Description
IBM UrbanCode Deploy (UCD) 7.0.5, 7.1.0, 7.1.1, and 7.1.2 uses weaker than expected cryptographic algorithms that could allow an attacker to decrypt highly sensitive information. IBM X-Force ID: 218859.
Affected products
- IBM UrbanCode Deploy: from 7.0.5.3 before 7.0.5.9; from 7.1.0.0 before 7.1.2.5 — fixed in 7.0.5.9, 7.1.2.5
How to fix
Upgrade to a fixed version: IBM UrbanCode Deploy 7.0.5.9, 7.1.2.5. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/218859
- https://www.ibm.com/support/pages/node/6568551
- https://exchange.xforce.ibmcloud.com/vulnerabilities/218859
- https://www.ibm.com/support/pages/node/6568551
Get alerted when CVE-2022-22327 or the next vulnerability affects your stack