What’s Vulnerable › Vulnerabilities
CVE-2022-22345
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-27 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM QRadar 7.3, 7.4, and 7.5 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 220041.
Affected products
- IBM QRadar SIEM: from 7.3.0 before 7.3.3; from 7.4.0 before 7.4.3; 7.3.3, 7.3.3-fix_pack_1, 7.3.3-fix_pack_2, 7.3.3-fix_pack_3, 7.3.3-fix_pack_4, 7.3.3-fix_pack_5 (+9) — fixed in 7.3.3, 7.4.3
How to fix
Upgrade to a fixed version: IBM QRadar SIEM 7.3.3, 7.4.3. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/220041
- https://www.ibm.com/support/pages/node/6574453
- https://exchange.xforce.ibmcloud.com/vulnerabilities/220041
- https://www.ibm.com/support/pages/node/6574453
Get alerted when CVE-2022-22345 or the next vulnerability affects your stack