What’s Vulnerable › Vulnerabilities
CVE-2022-22417
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-19 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM Sterling Partner Engagement Manager 6.1.2, 6.2, and Cloud/SasS 22.2 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 223127.
Affected products
- IBM Partner Engagement Manager: from 6.1.2 before 6.1.2.5; from 6.2.0 before 6.2.0.3 — fixed in 6.1.2.5, 6.2.0.3
- IBM Partner Engagement Manager On Cloud/Saas: 22.2
How to fix
Upgrade to a fixed version: IBM Partner Engagement Manager 6.1.2.5, 6.2.0.3. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/223127
- https://www.ibm.com/support/pages/node/6604991
- https://exchange.xforce.ibmcloud.com/vulnerabilities/223127
- https://www.ibm.com/support/pages/node/6604991
Get alerted when CVE-2022-22417 or the next vulnerability affects your stack