What’s Vulnerable › Vulnerabilities
CVE-2022-22476
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-08 · updated 2026-06-17
- Weakness: CWE-290
Description
IBM WebSphere Application Server Liberty 17.0.0.3 through 22.0.0.7 and Open Liberty are vulnerable to identity spoofing by an authenticated user using a specially crafted request. IBM X-Force ID: 225604.
Affected products
- IBM Open Liberty: from 17.0.0.3 before 22.0.0.8 — fixed in 22.0.0.8
- IBM WebSphere Application Server: from 17.0.0.3 before 22.0.0.8 — fixed in 22.0.0.8
How to fix
Upgrade to a fixed version: IBM Open Liberty 22.0.0.8; IBM WebSphere Application Server 22.0.0.8. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/225604
- https://www.ibm.com/support/pages/node/6602015
- https://exchange.xforce.ibmcloud.com/vulnerabilities/225604
- https://www.ibm.com/support/pages/node/6602015
Get alerted when CVE-2022-22476 or the next vulnerability affects your stack