What’s Vulnerable › Vulnerabilities
CVE-2022-22508: CODESYS V3: Improper Input Validation
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-15 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in multiple CODESYS V3 products allows an authenticated remote attacker to block consecutive logins of a specific type.
Affected products
- CODESYS Control for BeagleBone SL: before 4.7.0.0 — fixed in 4.7.0.0
- CODESYS Control For Empc-A/Imx6 Sl: before 4.7.0.0 — fixed in 4.7.0.0
- CODESYS Control for IOT2000 SL: before 4.7.0.0 — fixed in 4.7.0.0
- CODESYS Control for Linux SL: before 4.7.0.0 — fixed in 4.7.0.0
- CODESYS Control for PFC100 SL: before 4.7.0.0 — fixed in 4.7.0.0
- CODESYS Control for PFC200 SL: before 4.7.0.0 — fixed in 4.7.0.0
- CODESYS Control for PLCnext SL: before 4.7.0.0 — fixed in 4.7.0.0
- CODESYS Control for Raspberry Pi SL: before 4.7.0.0 — fixed in 4.7.0.0
- CODESYS Control for WAGO Touch Panels 600 SL: before 4.7.0.0 — fixed in 4.7.0.0
- CODESYS Control Rte (For Beckhoff Cx) Sl: before 3.5.18.40 — fixed in 3.5.18.40
- CODESYS Control Rte (Sl): before 3.5.18.40 — fixed in 3.5.18.40
- CODESYS Control Runtime System Toolkit: before 3.5.18.40 — fixed in 3.5.18.40
- CODESYS Control Win (Sl): before 3.5.18.40 — fixed in 3.5.18.40
- CODESYS Hmi (Sl): before 3.5.18.40 — fixed in 3.5.18.40
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone SL 4.7.0.0; CODESYS Control For Empc-A/Imx6 Sl 4.7.0.0; CODESYS Control for IOT2000 SL 4.7.0.0; CODESYS Control for Linux SL 4.7.0.0; CODESYS Control for PFC100 SL 4.7.0.0; CODESYS Control for PFC200 SL 4.7.0.0; CODESYS Control for PLCnext SL 4.7.0.0; CODESYS Control for Raspberry Pi SL 4.7.0.0; CODESYS Control for WAGO Touch Panels 600 SL 4.7.0.0; CODESYS Control Rte (For Beckhoff Cx) Sl 3.5.18.40; CODESYS Control Rte (Sl) 3.5.18.40; CODESYS Control Runtime System Toolkit 3.5.18.40. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17351&token=a7c02b2825fea2bcaf80c1a8e62097d72ec90f1a&download=
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17351&token=a7c02b2825fea2bcaf80c1a8e62097d72ec90f1a&download=
Get alerted when CVE-2022-22508 or the next vulnerability affects your stack