What’s Vulnerable › Vulnerabilities
CVE-2022-22514: Untrusted Pointer Dereference in multiple CODESYS products can lead to a DoS.
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-07 · updated 2026-06-17
- Weakness: CWE-822
Description
An authenticated, remote attacker can gain access to a dereferenced pointer contained in a request. The accesses can subsequently lead to local overwriting of memory in the CmpTraceMgr, whereby the attacker can neither gain the values read internally nor control the values to be written. If invalid memory is accessed, this results in a crash.
Affected products
- CODESYS Control for BeagleBone SL: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control For Beckhoff Cx9020: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control For Empc-A/Imx6 Sl: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control for IOT2000 SL: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control for Linux SL: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control for PFC100 SL: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control for PFC200 SL: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control for PLCnext SL: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control for Raspberry Pi SL: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control for WAGO Touch Panels 600 SL: before 4.5.0.0 — fixed in 4.5.0.0
- CODESYS Control RTE (SL): before 3.5.18.0 — fixed in 3.5.18.0
- CODESYS Control Rte Sl (For Beckhoff Cx): before 3.5.18.0 — fixed in 3.5.18.0
- CODESYS Control Runtime System Toolkit: before 3.5.18.0 — fixed in 3.5.18.0
- CODESYS Control Win (SL): before 3.5.18.0 — fixed in 3.5.18.0
- CODESYS Development System: from 3.0 before 3.5.18.0 — fixed in 3.5.18.0
- CODESYS Edge Gateway: before 3.5.18.0; before 4.5.0.0 — fixed in 3.5.18.0, 4.5.0.0
- CODESYS Embedded Target Visu Toolkit: before 3.5.18.0 — fixed in 3.5.18.0
- CODESYS Gateway Server V2: before 3.5.18.0 — fixed in 3.5.18.0
- CODESYS HMI (SL): before 3.5.18.0 — fixed in 3.5.18.0
- CODESYS Remote Target Visu Toolkit: before 3.5.18.0 — fixed in 3.5.18.0
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone SL 4.5.0.0; CODESYS Control For Beckhoff Cx9020 4.5.0.0; CODESYS Control For Empc-A/Imx6 Sl 4.5.0.0; CODESYS Control for IOT2000 SL 4.5.0.0; CODESYS Control for Linux SL 4.5.0.0; CODESYS Control for PFC100 SL 4.5.0.0; CODESYS Control for PFC200 SL 4.5.0.0; CODESYS Control for PLCnext SL 4.5.0.0; CODESYS Control for Raspberry Pi SL 4.5.0.0; CODESYS Control for WAGO Touch Panels 600 SL 4.5.0.0; CODESYS Control RTE (SL) 3.5.18.0; CODESYS Control Rte Sl (For Beckhoff Cx) 3.5.18.0. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17093&token=15cd8424832ea10dcd4873a409a09a539ee381ca&download=
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17093&token=15cd8424832ea10dcd4873a409a09a539ee381ca&download=
Get alerted when CVE-2022-22514 or the next vulnerability affects your stack