What’s Vulnerable › Vulnerabilities
CVE-2022-2255
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-25 · updated 2026-06-17
- Weakness: CWE-348
Description
A vulnerability was found in mod_wsgi. The X-Client-IP header is not removed from a request from an untrusted proxy, allowing an attacker to pass the X-Client-IP header to the target WSGI application because the condition to remove it is missing.
Affected products
- Debian Linux: 10.0
- mod_wsgi: before 4.9.3 — fixed in 4.9.3
How to fix
Upgrade to a fixed version: mod_wsgi 4.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/GrahamDumpleton/mod_wsgi/blob/4.9.2/src/server/mod_wsgi.c#L13940-L13941
- https://github.com/GrahamDumpleton/mod_wsgi/blob/4.9.2/src/server/mod_wsgi.c#L14046-L14082
- https://lists.debian.org/debian-lts-announce/2022/09/msg00021.html
- https://modwsgi.readthedocs.io/en/latest/release-notes/version-4.9.3.html
- https://github.com/GrahamDumpleton/mod_wsgi/blob/4.9.2/src/server/mod_wsgi.c#L13940-L13941
- https://github.com/GrahamDumpleton/mod_wsgi/blob/4.9.2/src/server/mod_wsgi.c#L14046-L14082
- https://lists.debian.org/debian-lts-announce/2022/09/msg00021.html
- https://modwsgi.readthedocs.io/en/latest/release-notes/version-4.9.3.html
Get alerted when CVE-2022-2255 or the next vulnerability affects your stack