What’s Vulnerable › Vulnerabilities
CVE-2022-22557
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-02 · updated 2026-06-17
- Weakness: CWE-256
Description
PowerStore contains Plain-Text Password Storage Vulnerability in PowerStore X & T environments running versions 2.0.0.x and 2.0.1.x A locally authenticated attacker could potentially exploit this vulnerability, leading to the disclosure of certain user credentials. The attacker may be able to use the exposed credentials to access the vulnerable application with privileges of the compromised account.
Affected products
- Dell PowerStore: from 2.0.0.0 before 2.1.0.0; from 2.0.0.0 before 2.1.1.0 — fixed in 2.1.0.0, 2.1.1.0
How to fix
Upgrade to a fixed version: Dell PowerStore 2.1.0.0, 2.1.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-22557 or the next vulnerability affects your stack