What’s Vulnerable › Vulnerabilities
CVE-2022-2257: Out-of-bounds Read in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-30 · updated 2026-10-08
- Weakness: CWE-125
Description
Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.
Affected products
- Fedoraproject Fedora: 35, 36
- vim/vim: before 9.0.0009 — fixed in 9.0.0009
How to fix
Upgrade to a fixed version: vim/vim 9.0.0009. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/083692d598139228e101b8c521aaef7bcf256e9a
- https://huntr.dev/bounties/ca581f80-03ba-472a-b820-78f7fd05fe89
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UXPO5EHDV6J4B27E65DOQGZFELUFPRSK/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/083692d598139228e101b8c521aaef7bcf256e9a
- https://huntr.dev/bounties/ca581f80-03ba-472a-b820-78f7fd05fe89
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UXPO5EHDV6J4B27E65DOQGZFELUFPRSK/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2257 or the next vulnerability affects your stack