What’s Vulnerable › Vulnerabilities

CVE-2022-22577: Cross-site Scripting Vulnerability in Action Pack

Description

An XSS Vulnerability in Action Pack >= 5.2.0 and < 5.2.0 that could allow an attacker to bypass CSP for non HTML like responses.

Affected products

How to fix

Upgrade to a fixed version: rails actionpack 5.2.7.1, 6.0.4.8, 6.1.5.1, 7.0.2.4; Rubygems Actionpack 5.2.7.1, 6.0.4.8, 6.1.5.1, 7.0.2.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-22577 or the next vulnerability affects your stack