What’s Vulnerable › Vulnerabilities
CVE-2022-2261: WPide < 3.0 - Admin+ Local File Inclusion
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-22
Description
The WPIDE WordPress plugin before 3.0 does not sanitize and validate the filename parameter before using it in a require statement in the admin dashboard, leading to a Local File Inclusion issue.
Affected products
- XplodedThemes WPIDE – File Manager & Code Editor: before 3.0 — fixed in 3.0
How to fix
Upgrade to a fixed version: XplodedThemes WPIDE – File Manager & Code Editor 3.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f6091d7b-97b5-42f2-b2f4-09a0fe6d5a21
- https://wpscan.com/vulnerability/f6091d7b-97b5-42f2-b2f4-09a0fe6d5a21
Get alerted when CVE-2022-2261 or the next vulnerability affects your stack