What’s Vulnerable › Vulnerabilities
CVE-2022-22610
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-23 · updated 2026-06-17
- Weakness: CWE-787
Description
A memory corruption issue was addressed with improved state management. This issue is fixed in macOS Monterey 12.3, Safari 15.4, watchOS 8.5, iOS 15.4 and iPadOS 15.4, tvOS 15.4. Processing maliciously crafted web content may lead to code execution.
Affected products
- Apple Ipad Os: before 15.4 — fixed in 15.4
- Apple Iphone Os: before 15.4 — fixed in 15.4
- Apple macOS: from 12.0 before 12.3 — fixed in 12.3
- Apple Safari: before 15.4 — fixed in 15.4
- Apple tvOS: before 15.4 — fixed in 15.4
- Apple watchOS: before 8.5 — fixed in 8.5
How to fix
Upgrade to a fixed version: Apple Ipad Os 15.4; Apple Iphone Os 15.4; Apple macOS 12.3; Apple Safari 15.4; Apple tvOS 15.4; Apple watchOS 8.5. Check the vendor advisory for mitigations.
References
- https://support.apple.com/en-us/HT213182
- https://support.apple.com/en-us/HT213183
- https://support.apple.com/en-us/HT213186
- https://support.apple.com/en-us/HT213187
- https://support.apple.com/en-us/HT213193
- https://support.apple.com/en-us/HT213182
- https://support.apple.com/en-us/HT213183
- https://support.apple.com/en-us/HT213186
- https://support.apple.com/en-us/HT213187
- https://support.apple.com/en-us/HT213193
Get alerted when CVE-2022-22610 or the next vulnerability affects your stack