What’s Vulnerable › Vulnerabilities
CVE-2022-22611
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-18 · updated 2026-06-17
- Weakness: CWE-125
Description
An out-of-bounds read was addressed with improved input validation. This issue is fixed in tvOS 15.4, iOS 15.4 and iPadOS 15.4, iTunes 12.12.3 for Windows, watchOS 8.5, macOS Monterey 12.3. Processing a maliciously crafted image may lead to arbitrary code execution.
Affected products
- Apple iPadOS: before 15.4 — fixed in 15.4
- Apple Iphone Os: before 15.4 — fixed in 15.4
- Apple iTunes for Windows: before 12.12.3 — fixed in 12.12.3
- Apple macOS: from 12.0 before 12.3 — fixed in 12.3
- Apple tvOS: before 15.4 — fixed in 15.4
- Apple watchOS: before 8.5 — fixed in 8.5
How to fix
Upgrade to a fixed version: Apple iPadOS 15.4; Apple Iphone Os 15.4; Apple iTunes for Windows 12.12.3; Apple macOS 12.3; Apple tvOS 15.4; Apple watchOS 8.5. Check the vendor advisory for mitigations.
References
- https://support.apple.com/en-us/HT213182
- https://support.apple.com/en-us/HT213183
- https://support.apple.com/en-us/HT213186
- https://support.apple.com/en-us/HT213188
- https://support.apple.com/en-us/HT213193
- https://support.apple.com/en-us/HT213182
- https://support.apple.com/en-us/HT213183
- https://support.apple.com/en-us/HT213186
- https://support.apple.com/en-us/HT213188
- https://support.apple.com/en-us/HT213193
Get alerted when CVE-2022-22611 or the next vulnerability affects your stack