What’s Vulnerable › Vulnerabilities
CVE-2022-22617
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-18 · updated 2026-06-17
Description
A logic issue was addressed with improved state management. This issue is fixed in macOS Big Sur 11.6.5, macOS Monterey 12.3, Security Update 2022-003 Catalina. An application may be able to gain elevated privileges.
Affected products
- macOS: from 10.15 before 10.15.7; 10.15.7-security_update_2020-001, 10.15.7-security_update_2021-001, 10.15.7-security_update_2021-002, 10.15.7-security_update_2021-003, 10.15.7-security_update_2021-004, 10.15.7-security_update_2021-005 (+5) — fixed in 10.15.7
- Apple macOS: before 11.6.5; from 12.0.0 before 12.4; 10.15.7, 10.15.7-supplemental_update — fixed in 11.6.5, 12.4
How to fix
Upgrade to a fixed version: macOS 10.15.7; Apple macOS 11.6.5, 12.4. Check the vendor advisory for mitigations.
References
- https://support.apple.com/en-us/HT213183
- https://support.apple.com/en-us/HT213184
- https://support.apple.com/en-us/HT213185
- https://support.apple.com/kb/HT213257
- https://support.apple.com/en-us/HT213183
- https://support.apple.com/en-us/HT213184
- https://support.apple.com/en-us/HT213185
- https://support.apple.com/kb/HT213257
Get alerted when CVE-2022-22617 or the next vulnerability affects your stack