What’s Vulnerable › Vulnerabilities
CVE-2022-2267: MailChimp for Woocommerce < 2.7.1 - Subscriber+ SSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-918
Description
The Mailchimp for WooCommerce WordPress plugin before 2.7.1 has an AJAX action that allows any logged in users (such as subscriber) to perform a POST request on behalf of the server to the internal network/LAN, the body of the request is also appended to the response so it can be used to scan private network for example
Affected products
- Mailchimp for WooCommerce: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: Mailchimp for WooCommerce 2.7.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e3bd9f8c-919a-40af-9e80-607573e71870
- https://wpscan.com/vulnerability/e3bd9f8c-919a-40af-9e80-607573e71870
Get alerted when CVE-2022-2267 or the next vulnerability affects your stack