What’s Vulnerable › Vulnerabilities
CVE-2022-22682
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper neutralization of input during web page generation ('Cross-site Scripting') vulnerability in Event Management in Synology Calendar before 2.4.5-10930 allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.
Affected products
- Synology Calendar: before 2.4.5-10930 — fixed in 2.4.5-10930
How to fix
Upgrade to a fixed version: Synology Calendar 2.4.5-10930. Check the vendor advisory for mitigations.
References
- https://www.synology.com/security/advisory/Synology_SA_22_07
- https://www.synology.com/security/advisory/Synology_SA_22_07
Get alerted when CVE-2022-22682 or the next vulnerability affects your stack