What’s Vulnerable › Vulnerabilities
CVE-2022-22683
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-28 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer copy without checking size of input ('Classic Buffer Overflow') vulnerability in cgi component in Synology Media Server before 1.8.1-2876 allows remote attackers to execute arbitrary code via unspecified vectors.
Affected products
- Synology Media Server: before 1.8.1-2876; before 1.4-2665 — fixed in 1.4-2665, 1.8.1-2876
How to fix
Upgrade to a fixed version: Synology Media Server 1.4-2665, 1.8.1-2876. Check the vendor advisory for mitigations.
References
- https://www.synology.com/security/advisory/Synology_SA_20_24
- https://www.synology.com/security/advisory/Synology_SA_20_24
Get alerted when CVE-2022-22683 or the next vulnerability affects your stack