What’s Vulnerable › Vulnerabilities
CVE-2022-2271: WP Database Backup < 5.9 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Database Backup WordPress plugin before 5.9 does not escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- databasebackup WP Database Backup – Unlimited Database & Files Backup by Backup for WP: before 5.9 — fixed in 5.9
How to fix
Upgrade to a fixed version: databasebackup WP Database Backup – Unlimited Database & Files Backup by Backup for WP 5.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b064940f-9614-4b7b-b2c4-e79528746833
- https://wpscan.com/vulnerability/b064940f-9614-4b7b-b2c4-e79528746833
Get alerted when CVE-2022-2271 or the next vulnerability affects your stack