What’s Vulnerable › Vulnerabilities
CVE-2022-2275: WP Edit Menu <= 1.5.0 - Arbitrary Post Deletion via CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-22 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP Edit Menu WordPress plugin before 1.5.0 does not have CSRF in an AJAX action, which could allow attackers to make a logged in admin delete arbitrary posts/pages from the blog via a CSRF attack
Affected products
- WP Edit Menu: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: WP Edit Menu 1.5.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/07757d1e-39ad-4199-bc7a-ecb821dfc996
- https://wpscan.com/vulnerability/07757d1e-39ad-4199-bc7a-ecb821dfc996
Get alerted when CVE-2022-2275 or the next vulnerability affects your stack