What’s Vulnerable › Vulnerabilities
CVE-2022-22754
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-863
Description
If a user installed an extension of a particular type, the extension could have auto-updated itself and while doing so, bypass the prompt which grants the new version the new requested permissions. This vulnerability affects Firefox < 97, Thunderbird < 91.6, and Firefox ESR < 91.6.
Affected products
- Mozilla Firefox: before 97.0 — fixed in 97.0
- Mozilla Firefox ESR: before 91.6 — fixed in 91.6
- Mozilla Thunderbird: before 91.6 — fixed in 91.6
How to fix
Upgrade to a fixed version: Mozilla Firefox 97.0; Mozilla Firefox ESR 91.6; Mozilla Thunderbird 91.6. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1750565
- https://www.mozilla.org/security/advisories/mfsa2022-04/
- https://www.mozilla.org/security/advisories/mfsa2022-05/
- https://www.mozilla.org/security/advisories/mfsa2022-06/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1750565
- https://www.mozilla.org/security/advisories/mfsa2022-04/
- https://www.mozilla.org/security/advisories/mfsa2022-05/
- https://www.mozilla.org/security/advisories/mfsa2022-06/
Get alerted when CVE-2022-22754 or the next vulnerability affects your stack