What’s Vulnerable › Vulnerabilities
CVE-2022-2276: WP Edit Menu < 1.5.0 - Unauthenticated Arbitrary Post Deletion
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-22 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP Edit Menu WordPress plugin before 1.5.0 does not have authorisation and CSRF in an AJAX action, which could allow unauthenticated attackers to delete arbitrary posts/pages from the blog
Affected products
- WP Edit Menu: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: WP Edit Menu 1.5.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?new=2749780%40wp-edit-menu%2Ftrunk&old=2220186%40wp-edit-menu%2Ftrunk
- https://wpscan.com/vulnerability/92de9c1b-48dd-4a5f-bbb3-455f8f172b09
- https://plugins.trac.wordpress.org/changeset?new=2749780%40wp-edit-menu%2Ftrunk&old=2220186%40wp-edit-menu%2Ftrunk
- https://wpscan.com/vulnerability/92de9c1b-48dd-4a5f-bbb3-455f8f172b09
Get alerted when CVE-2022-2276 or the next vulnerability affects your stack