What’s Vulnerable › Vulnerabilities
CVE-2022-22761
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-693
Description
Web-accessible extension pages (pages with a moz-extension:// scheme) were not correctly enforcing the frame-ancestors directive when it was used in the Web Extension's Content Security Policy. This vulnerability affects Firefox < 97, Thunderbird < 91.6, and Firefox ESR < 91.6.
Affected products
- Mozilla Firefox: before 97.0 — fixed in 97.0
- Mozilla Firefox ESR: before 91.6 — fixed in 91.6
- Mozilla Thunderbird: before 91.6 — fixed in 91.6
How to fix
Upgrade to a fixed version: Mozilla Firefox 97.0; Mozilla Firefox ESR 91.6; Mozilla Thunderbird 91.6. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1745566
- https://www.mozilla.org/security/advisories/mfsa2022-04/
- https://www.mozilla.org/security/advisories/mfsa2022-05/
- https://www.mozilla.org/security/advisories/mfsa2022-06/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1745566
- https://www.mozilla.org/security/advisories/mfsa2022-04/
- https://www.mozilla.org/security/advisories/mfsa2022-05/
- https://www.mozilla.org/security/advisories/mfsa2022-06/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1745566
Get alerted when CVE-2022-22761 or the next vulnerability affects your stack