What’s Vulnerable › Vulnerabilities
CVE-2022-2280: Cross-site Scripting (XSS) - Stored in microweber/microweber
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository microweber/microweber prior to 1.2.19.
Affected products
- microweber/microweber: before 1.2.19 — fixed in 1.2.19
How to fix
Upgrade to a fixed version: microweber/microweber 1.2.19. Check the vendor advisory for mitigations.
References
- https://github.com/microweber/microweber/commit/9ebbb4dd35da74025ab6965f722829a7f8f86566
- https://huntr.dev/bounties/22561bfd-a28f-474e-9bfd-7263c1b71133
- https://github.com/microweber/microweber/commit/9ebbb4dd35da74025ab6965f722829a7f8f86566
- https://huntr.dev/bounties/22561bfd-a28f-474e-9bfd-7263c1b71133
Get alerted when CVE-2022-2280 or the next vulnerability affects your stack