What’s Vulnerable › Vulnerabilities

CVE-2022-22818: Cross-site Scripting in Django

Description

The {% debug %} template tag in Django 2.2 before 2.2.27, 3.2 before 3.2.12, and 4.0 before 4.0.2 does not properly encode the current context. This may lead to XSS.

Affected products

How to fix

Upgrade to a fixed version: Django 2.2.27, 3.2.12, 4.0.2; Pypi Django 2.2.27, 3.2.12, 4.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-22818 or the next vulnerability affects your stack