What’s Vulnerable › Vulnerabilities
CVE-2022-22825
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-10 · updated 2026-10-14
- Weakness: CWE-190
Description
lookup in xmlparse.c in Expat (aka libexpat) before 2.4.3 has an integer overflow.
Affected products
- Debian Linux: 10.0, 11.0
- libexpat project libexpat: before 2.4.3 — fixed in 2.4.3
- Siemens SINEMA Remote Connect Server: before 3.1 — fixed in 3.1
- Tenable Nessus: before 8.15.3; from 10.0.0 before 10.1.1 — fixed in 10.1.1, 8.15.3
How to fix
Upgrade to a fixed version: libexpat project libexpat 2.4.3; Siemens SINEMA Remote Connect Server 3.1; Tenable Nessus 10.1.1, 8.15.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/17/3
- https://cert-portal.siemens.com/productcert/pdf/ssa-484086.pdf
- https://github.com/libexpat/libexpat/pull/539
- https://security.gentoo.org/glsa/202209-24
- https://www.debian.org/security/2022/dsa-5073
- https://www.tenable.com/security/tns-2022-05
- http://www.openwall.com/lists/oss-security/2022/01/17/3
- https://cert-portal.siemens.com/productcert/pdf/ssa-484086.pdf
- https://github.com/libexpat/libexpat/pull/539
- https://security.gentoo.org/glsa/202209-24
- https://www.debian.org/security/2022/dsa-5073
- https://www.tenable.com/security/tns-2022-05
Get alerted when CVE-2022-22825 or the next vulnerability affects your stack