What’s Vulnerable › Vulnerabilities
CVE-2022-2284: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-02 · updated 2026-10-08
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.
Affected products
- Fedoraproject Fedora: 35, 36
- vim/vim: before 9.0.0017 — fixed in 9.0.0017
How to fix
Upgrade to a fixed version: vim/vim 9.0.0017. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/3d51ce18ab1be4f9f6061568a4e7fabf00b21794
- https://huntr.dev/bounties/571d25ce-8d53-4fa0-b620-27f2a8a14874
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UXPO5EHDV6J4B27E65DOQGZFELUFPRSK/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/3d51ce18ab1be4f9f6061568a4e7fabf00b21794
- https://huntr.dev/bounties/571d25ce-8d53-4fa0-b620-27f2a8a14874
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UXPO5EHDV6J4B27E65DOQGZFELUFPRSK/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2284 or the next vulnerability affects your stack