What’s Vulnerable › Vulnerabilities
CVE-2022-2285: Integer Overflow or Wraparound in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-02 · updated 2026-10-08
- Weakness: CWE-190
Description
Integer Overflow or Wraparound in GitHub repository vim/vim prior to 9.0.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 35, 36
- vim/vim: before 9.0.0018 — fixed in 9.0.0018
How to fix
Upgrade to a fixed version: vim/vim 9.0.0018. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/27efc62f5d86afcb2ecb7565587fe8dea4b036fe
- https://huntr.dev/bounties/64574b28-1779-458d-a221-06c434042736
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UXPO5EHDV6J4B27E65DOQGZFELUFPRSK/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/27efc62f5d86afcb2ecb7565587fe8dea4b036fe
- https://huntr.dev/bounties/64574b28-1779-458d-a221-06c434042736
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UXPO5EHDV6J4B27E65DOQGZFELUFPRSK/
Get alerted when CVE-2022-2285 or the next vulnerability affects your stack