What’s Vulnerable › Vulnerabilities
CVE-2022-2286: Out-of-bounds Read in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-02 · updated 2026-10-08
- Weakness: CWE-125
Description
Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.
Affected products
- Fedoraproject Fedora: 35, 36
- vim/vim: before 9.0.0020 — fixed in 9.0.0020
How to fix
Upgrade to a fixed version: vim/vim 9.0.0020. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/f12129f1714f7d2301935bb21d896609bdac221c
- https://huntr.dev/bounties/fe7681fb-2318-436b-8e65-daf66cd597d8
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UXPO5EHDV6J4B27E65DOQGZFELUFPRSK/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/f12129f1714f7d2301935bb21d896609bdac221c
- https://huntr.dev/bounties/fe7681fb-2318-436b-8e65-daf66cd597d8
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UXPO5EHDV6J4B27E65DOQGZFELUFPRSK/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2286 or the next vulnerability affects your stack