What’s Vulnerable › Vulnerabilities
CVE-2022-2289: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-03 · updated 2026-06-17
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 9.0.
Affected products
- Fedoraproject Fedora: 35, 36
- vim/vim: before 9.0.0026 — fixed in 9.0.0026
How to fix
Upgrade to a fixed version: vim/vim 9.0.0026. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/c5274dd12224421f2430b30c53b881b9403d649e
- https://huntr.dev/bounties/7447d2ea-db5b-4883-adf4-1eaf7deace64
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UXPO5EHDV6J4B27E65DOQGZFELUFPRSK/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/c5274dd12224421f2430b30c53b881b9403d649e
- https://huntr.dev/bounties/7447d2ea-db5b-4883-adf4-1eaf7deace64
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UXPO5EHDV6J4B27E65DOQGZFELUFPRSK/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2289 or the next vulnerability affects your stack