What’s Vulnerable › Vulnerabilities
CVE-2022-22912
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-17 · updated 2026-06-17
- Weakness: CWE-1321
Description
Prototype pollution vulnerability via .parse() in Plist before v3.0.4 allows attackers to cause a Denial of Service (DoS) and may lead to remote code execution.
Affected products
- Plist Project Plist: before 3.0.6 — fixed in 3.0.6
How to fix
Upgrade to a fixed version: Plist Project Plist 3.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/TooTallNate/plist.js/issues/114
- https://github.com/TooTallNate/plist.js/issues/114
Get alerted when CVE-2022-22912 or the next vulnerability affects your stack