What’s Vulnerable › Vulnerabilities
CVE-2022-22944
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-02 · updated 2026-06-17
- Weakness: CWE-79
Description
VMware Workspace ONE Boxer contains a stored cross-site scripting (XSS) vulnerability. Due to insufficient sanitization and validation, in VMware Workspace ONE Boxer calendar event descriptions, a malicious actor can inject script tags to execute arbitrary script within a user's window.
Affected products
- VMware Workspace ONE Boxer: before 22.02 — fixed in 22.02
- VMware Workspace ONE Boxer: VMware Workspace ONE Boxer for iOS prior to 22.02
How to fix
Upgrade to a fixed version: VMware Workspace ONE Boxer 22.02. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2022-0006.html
- https://www.vmware.com/security/advisories/VMSA-2022-0006.html
Get alerted when CVE-2022-22944 or the next vulnerability affects your stack