What’s Vulnerable › Vulnerabilities
CVE-2022-22945
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-16 · updated 2026-06-17
- Weakness: CWE-78
Description
VMware NSX Edge contains a CLI shell injection vulnerability. A malicious actor with SSH access to an NSX-Edge appliance can execute arbitrary commands on the operating system as root.
Affected products
- VMware Cloud Foundation: from 3.0 through 3.11
- VMware Nsx Data Center: before 6.4.13 — fixed in 6.4.13
- VMware NSX Edge: 6.4.10
How to fix
Upgrade to a fixed version: VMware Nsx Data Center 6.4.13. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2022-0005.html
- https://www.vmware.com/security/advisories/VMSA-2022-0005.html
Get alerted when CVE-2022-22945 or the next vulnerability affects your stack