What’s Vulnerable › Vulnerabilities

CVE-2022-22950

Description

n Spring Framework versions 5.3.0 - 5.3.16 and older unsupported versions, it is possible for a user to provide a specially crafted SpEL expression that may cause a denial of service condition.

Affected products

How to fix

Upgrade to a fixed version: Spring Framework 5.2.20, 5.3.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-22950 or the next vulnerability affects your stack