What’s Vulnerable › Vulnerabilities
CVE-2022-22959
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-13 · updated 2026-06-17
- Weakness: CWE-352
Description
VMware Workspace ONE Access, Identity Manager and vRealize Automation contain a cross site request forgery vulnerability. A malicious actor can trick a user through a cross site request forgery to unintentionally validate a malicious JDBC URI.
Affected products
- VMware Cloud Foundation: from 3.0 before 5.0 — fixed in 5.0
- VMware Identity Manager: 3.3.3, 3.3.4, 3.3.5, 3.3.6
- VMware vRealize Automation: from 8.0 before 9.0; 7.6 — fixed in 9.0
- VMware Vrealize Suite Lifecycle Manager: from 8.0 before 9.0 — fixed in 9.0
- VMware Workspace ONE Access: 20.10.0.0, 20.10.0.1, 21.08.0.0, 21.08.0.1
- VMware Workspace ONE Access, Identity Manager and vRealize Automation: Access 21.08.0.1, 21.08.0.0, 20.10.0.1, 20.10.0.0. Identity Manager 3.3.6, 3.3.5, 3.3.4, 3.3.3. vRealize Automation 7.6.
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 5.0; VMware vRealize Automation 9.0; VMware Vrealize Suite Lifecycle Manager 9.0. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2022-0011.html
- https://www.vmware.com/security/advisories/VMSA-2022-0011.html
Get alerted when CVE-2022-22959 or the next vulnerability affects your stack