What’s Vulnerable › Vulnerabilities
CVE-2022-22960: VMware Multiple Products Privilege Escalation Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-04-15
- EPSS: 35.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-13 · updated 2026-06-17
- Weakness: CWE-732
Description
VMware Workspace ONE Access, Identity Manager and vRealize Automation contain a privilege escalation vulnerability due to improper permissions in support scripts. A malicious actor with local access can escalate privileges to 'root'.
Affected products
- VMware Cloud Foundation: from 3.0 before 5.0 — fixed in 5.0
- VMware Identity Manager: 3.3.3, 3.3.4, 3.3.5, 3.3.6
- VMware vRealize Automation: 7.6
- VMware Vrealize Suite Lifecycle Manager: from 8.0 before 9.0 — fixed in 9.0
- VMware Workspace ONE Access: 20.10.0.0, 20.10.0.1, 21.08.0.0, 21.08.0.1
- VMware Workspace ONE Access, Identity Manager and vRealize Automation: Access 21.08.0.1, 21.08.0.0, 20.10.0.1, 20.10.0.0. Identity Manager 3.3.6, 3.3.5, 3.3.4, 3.3.3. vRealize Automation 7.6.
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 5.0; VMware Vrealize Suite Lifecycle Manager 9.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/171918/Mware-Workspace-ONE-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/171918/VMware-Workspace-ONE-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/171935/VMware-Workspace-ONE-Access-Privilege-Escalation.html
- https://www.vmware.com/security/advisories/VMSA-2022-0011.html
- http://packetstormsecurity.com/files/171918/Mware-Workspace-ONE-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/171918/VMware-Workspace-ONE-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/171935/VMware-Workspace-ONE-Access-Privilege-Escalation.html
- https://www.vmware.com/security/advisories/VMSA-2022-0011.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2022-22960
Get alerted when CVE-2022-22960 or the next vulnerability affects your stack