What’s Vulnerable › Vulnerabilities

CVE-2022-22968

Description

In Spring Framework versions 5.3.0 - 5.3.18, 5.2.0 - 5.2.20, and older unsupported versions, the patterns for disallowedFields on a DataBinder are case sensitive which means a field is not effectively protected unless it is listed with both upper and lower case for the first character of the field, including upper and lower case for the first character of all nested fields within the property path.

Affected products

How to fix

Upgrade to a fixed version: Spring Framework 5.2.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-22968 or the next vulnerability affects your stack