What’s Vulnerable › Vulnerabilities

CVE-2022-22969

Description

<Issue Description> Spring Security OAuth versions 2.5.x prior to 2.5.2 and older unsupported versions are susceptible to a Denial-of-Service (DoS) attack via the initiation of the Authorization Request in an OAuth 2.0 Client application. A malicious user or attacker can send multiple requests initiating the Authorization Request for the Authorization Code Grant, which has the potential of exhausting system resources using a single session. This vulnerability exposes OAuth 2.0 Client applications only.

Affected products

How to fix

Upgrade to a fixed version: Pivotal Spring Security Oauth 2.4.2, 2.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-22969 or the next vulnerability affects your stack