What’s Vulnerable › Vulnerabilities

CVE-2022-22976

Description

Spring Security versions 5.5.x prior to 5.5.7, 5.6.x prior to 5.6.4, and earlier unsupported versions contain an integer overflow vulnerability. When using the BCrypt class with the maximum work factor (31), the encoder does not perform any salt rounds, due to an integer overflow error. The default settings are not affected by this CVE.

Affected products

How to fix

Upgrade to a fixed version: Spring Security 5.5.7, 5.6.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-22976 or the next vulnerability affects your stack