What’s Vulnerable › Vulnerabilities

CVE-2022-22978

Description

In spring security versions prior to 5.4.11+, 5.5.7+ , 5.6.4+ and older unsupported versions, RegexRequestMatcher can easily be misconfigured to be bypassed on some servlet containers. Applications using RegexRequestMatcher with `.` in the regular expression are possibly vulnerable to an authorization bypass.

Affected products

How to fix

Upgrade to a fixed version: Spring Security 5.5.7, 5.6.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-22978 or the next vulnerability affects your stack