What’s Vulnerable › Vulnerabilities
CVE-2022-22983
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-09 · updated 2026-06-17
- Weakness: CWE-522
Description
VMware Workstation (16.x prior to 16.2.4) contains an unprotected storage of credentials vulnerability. A malicious actor with local user privileges to the victim machine may exploit this vulnerability leading to the disclosure of user passwords of the remote server connected through VMware Workstation.
Affected products
- VMware Workstation: from 16.0.0 before 16.2.4 — fixed in 16.2.4
- VMware Workstation: from VMware Workstation (16.x prior through 16.2.4)
How to fix
Upgrade to a fixed version: VMware Workstation 16.2.4. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2022-0023.html
- https://www.vmware.com/security/advisories/VMSA-2022-0023.html
Get alerted when CVE-2022-22983 or the next vulnerability affects your stack