What’s Vulnerable › Vulnerabilities
CVE-2022-22989: Pre-authenticated stack overflow vulnerability on FTP Service
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-13 · updated 2026-06-17
- Weakness: CWE-121
Description
My Cloud OS 5 was vulnerable to a pre-authenticated stack overflow vulnerability on the FTP service that could be exploited by unauthenticated attackers on the network. Addressed the vulnerability by adding defenses against stack overflow issues.
Affected products
- Western Digital My Cloud: before 5.19.117 — fixed in 5.19.117
How to fix
Upgrade to a fixed version: Western Digital My Cloud 5.19.117. Check the vendor advisory for mitigations.
References
- https://www.westerndigital.com/support/product-security/wdc-22002-my-cloud-os5-firmware-5-19-117
- https://www.westerndigital.com/support/product-security/wdc-22002-my-cloud-os5-firmware-5-19-117
Get alerted when CVE-2022-22989 or the next vulnerability affects your stack