What’s Vulnerable › Vulnerabilities
CVE-2022-23008
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-25 · updated 2026-06-17
- Weakness: CWE-94
Description
On NGINX Controller API Management versions 3.18.0-3.19.0, an authenticated attacker with access to the "user" or "admin" role can use undisclosed API endpoints on NGINX Controller API Management to inject JavaScript code that is executed on managed NGINX data plane instances. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- NGINX Controller API Management: from 3.18.0 before 3.19.1 — fixed in 3.19.1
How to fix
Upgrade to a fixed version: NGINX Controller API Management 3.19.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-23008 or the next vulnerability affects your stack