What’s Vulnerable › Vulnerabilities
CVE-2022-2301: Buffer Over-read in hpjansson/chafa
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-04 · updated 2026-06-17
- Weakness: CWE-126
Description
Buffer Over-read in GitHub repository hpjansson/chafa prior to 1.10.3.
Affected products
- hpjansson/chafa: before 1.10.3 — fixed in 1.10.3
How to fix
Upgrade to a fixed version: hpjansson/chafa 1.10.3. Check the vendor advisory for mitigations.
References
- https://github.com/hpjansson/chafa/commit/56fabfa18a6880b4cb66047fa6557920078048d9
- https://huntr.dev/bounties/f6b9114b-671d-4948-b946-ffe5c9aeb816
- https://github.com/hpjansson/chafa/commit/56fabfa18a6880b4cb66047fa6557920078048d9
- https://huntr.dev/bounties/f6b9114b-671d-4948-b946-ffe5c9aeb816
Get alerted when CVE-2022-2301 or the next vulnerability affects your stack