What’s Vulnerable › Vulnerabilities
CVE-2022-2303
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-05 · updated 2026-06-17
- Weakness: CWE-287
Description
An issue has been discovered in GitLab CE/EE affecting all versions before 15.0.5, all versions starting from 15.1 before 15.1.4, all versions starting from 15.2 before 15.2.1. It may be possible for group members to bypass 2FA enforcement enabled at the group level by using Resource Owner Password Credentials grant to obtain an access token without using 2FA.
Affected products
- GitLab: before 15.0.5; from 15.1.0 before 15.1.4; 15.2 — fixed in 15.0.5, 15.1.4
How to fix
Upgrade to a fixed version: GitLab 15.0.5, 15.1.4. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-2303.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/355028
- https://hackerone.com/reports/1498133
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-2303.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/355028
- https://hackerone.com/reports/1498133
Get alerted when CVE-2022-2303 or the next vulnerability affects your stack