What’s Vulnerable › Vulnerabilities
CVE-2022-2304: Stack-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-05 · updated 2026-10-08
- Weakness: CWE-121
Description
Stack-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 35, 36
- vim/vim: before 9.0.0035 — fixed in 9.0.0035
How to fix
Upgrade to a fixed version: vim/vim 9.0.0035. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/54e5fed6d27b747ff152cdb6edfb72ff60e70939
- https://huntr.dev/bounties/eb7402f3-025a-402f-97a7-c38700d9548a
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UXPO5EHDV6J4B27E65DOQGZFELUFPRSK/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/54e5fed6d27b747ff152cdb6edfb72ff60e70939
- https://huntr.dev/bounties/eb7402f3-025a-402f-97a7-c38700d9548a
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00023.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
Get alerted when CVE-2022-2304 or the next vulnerability affects your stack