What’s Vulnerable › Vulnerabilities
CVE-2022-23055: ERPNext - Improper user access conrol
- Severity: medium (CVSS 5.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-22 · updated 2026-06-17
- Weakness: CWE-862
Description
In ERPNext, versions v11.0.0-beta through v13.0.2 are vulnerable to Missing Authorization, in the chat rooms functionality. A low privileged attacker can send a direct message or a group message to any member or group, impersonating themselves as the administrator. The attacker can also read chat messages of groups that they do not belong to, and of other users.
Affected products
- frappe erpnext: from 11.0.4 before 13.1.0; 11.0.3-beta1, 11.0.3-beta10, 11.0.3-beta11, 11.0.3-beta12, 11.0.3-beta13, 11.0.3-beta14 (+31) — fixed in 13.1.0
How to fix
Upgrade to a fixed version: frappe erpnext 13.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/blob/v13.0.2/frappe/chat/doctype/chat_message/chat_message.py#L134
- https://github.com/frappe/frappe/blob/v13.0.2/frappe/chat/doctype/chat_message/chat_message.py#L155
- https://www.mend.io/vulnerability-database/CVE-2022-23055
- https://github.com/frappe/frappe/blob/v13.0.2/frappe/chat/doctype/chat_message/chat_message.py#L134
- https://github.com/frappe/frappe/blob/v13.0.2/frappe/chat/doctype/chat_message/chat_message.py#L155
- https://www.mend.io/vulnerability-database/CVE-2022-23055
Get alerted when CVE-2022-23055 or the next vulnerability affects your stack