What’s Vulnerable › Vulnerabilities
CVE-2022-23057: ERPNext - Stored XSS in My Profile
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-22 · updated 2026-06-17
- Weakness: CWE-79
Description
In ERPNext, versions v12.0.9--v13.0.3 are vulnerable to Stored Cross-Site-Scripting (XSS), due to user input not being validated properly. A low privileged attacker could inject arbitrary code into input fields when editing his profile.
Affected products
- frappe erpnext: from 12.0.9 before 13.1.0 — fixed in 13.1.0
How to fix
Upgrade to a fixed version: frappe erpnext 13.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/commit/497ea861f481c6a3c52fe2aed9d0df1b6c99e9d7
- https://www.mend.io/vulnerability-database/CVE-2022-23057
- https://github.com/frappe/frappe/commit/497ea861f481c6a3c52fe2aed9d0df1b6c99e9d7
- https://www.mend.io/vulnerability-database/CVE-2022-23057
Get alerted when CVE-2022-23057 or the next vulnerability affects your stack